Help! I can't install Office 365 on my Mac!

Bryan Gibson

Last Update vor 18 Tagen

If you see the above screen when attempting to install Office 365 to your Mac running macOS 10.14 or earlier, you will need to update to macOS 10.15 (Catalina) or later to continue.

These Mac models are compatible with macOS Catalina:


MacBook (Early 2015 or newer)

MacBook Air (Mid 2012 or newer)

MacBook Pro (Mid 2012 or newer)

Mac mini (Late 2012 or newer)

iMac (Late 2012 or newer)

iMac Pro (2017)

Mac Pro (Late 2013 or newer)

Unfortunately, if your Mac is older than the above mentioned models, you will not be able to install Office 365 applications to your computer.  You will only be able to use the online versions of the Office applications.

Was this article helpful?

0 out of 0 liked this article

Still need help? Message Us